Внимание! Форум временно закрыт. Все вопросы вы можете задать на странице MaxSite CMS в Github

mso_hook_add(head, ...) - не работает

В этом форуме вы можете задать вопрос по MaxSite CMS.
Аватар пользователя
tux
Сообщений: 128
Зарегистрирован: 19 фев 2009, 21:11

mso_hook_add(head, ...) - не работает

Сообщение tux » 19 фев 2009, 22:05

Код: Выбрать все

mso_hook_add( 'head',...

Решил написать плугин, обнаружил что не работает хук на хед.
Подключил стандартный "comment_button", который это использует - не работает.
версия 0.29
Не знаю что делать. переустанавливать целиком? или в конфигах что подправить?

Аватар пользователя
Saturn
Сообщений: 10
Зарегистрирован: 05 фев 2009, 15:20

Re: mso_hook_add(head, ...) - не работает

Сообщение Saturn » 20 фев 2009, 11:24

если например:

Код: Выбрать все

mso_hook_add( 'head', 'comment_button_func');

то существует ли функция comment_button_func ???
"Блажен король, но кружка с пивом
Любого сделает счастливым"
(c) Роберт Бернс

Аватар пользователя
tux
Сообщений: 128
Зарегистрирован: 19 фев 2009, 21:11

Re: mso_hook_add(head, ...) - не работает

Сообщение tux » 20 фев 2009, 11:55

да, правильно прописано и существует

возможно цмс криво встало или файлы побились
буду обновлять

Аватар пользователя
tux
Сообщений: 128
Зарегистрирован: 19 фев 2009, 21:11

Re: mso_hook_add(head, ...) - не работает

Сообщение tux » 20 фев 2009, 12:06

А все, проблема решена))))))))) :lol:
т.к. я делал шаблон по этой статье http://max-3000.com/page/1-delaem-svoj-shablon
я не вставил <?php mso_hook('head') ?> в шаблон


Вернуться в «MaxSite CMS»

Кто сейчас на форуме

Пользователь просматривает форум: нет зарегистрированных пользователей

cron